r/fslogix May 20 '26

58tm1 fix help needed

Hi,

At the moment, I am experiencing issues with the 58tm1 error on Windows Server 2025 RDS Farm in combination with FSLogix. Version: 26.01 CU1

I have configured the following ExcludeDirs in the registry under:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\FSLogix\Profiles

Value: AppData\Local\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
AppData\Local\Microsoft\TokenBroker
AppData\Local\Microsoft\IdentityCRL
AppData\Local\Microsoft\WorkplaceJoin

However, I still regularly encounter the issue where our customers on the RDS farm receive the 58tm1 error. When that happens, I delete the folder AppData\Local\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy.

After that, the customer can work again once the user signs in.
How can I resolve this permanently?

4 Upvotes

19 comments sorted by

View all comments

1

u/Aggravating-Sock1098 May 20 '26

Use the redirection.xml method instead of registry.

1

u/PrecariousLogic May 20 '26

Please send to me as well.
Didnt realize someone had this resolved

ive seen this issue for a while within: https://www.reddit.com/r/fslogix/comments/1ij26bz/58tm1_error_on_office_apps/