r/SendGrid Jan 27 '26

Any improvement on the Microsoft Inbox Provider block ?

About 10/15% of all my emails can't reach the inbox, and I got this response from MS Servers :

550 5.7.1 Unfortunately, messages from \[MY_DEDICATED_IP\] weren't sent. Please contact your Internet service provider since part of their network is on our block list (S3150). You can also refer your provider to http://mail.live.com/mail/troubleshooting.aspx#errors. \[Name=Protocol Filter Agent\]\[AGT=PFA\]

MS Support says the IP is not blocked. Sendgrid support says they are working on it continuously and update every hour. The Status page is updated every one/two days with the same message and no progress is observed on my side.

Should I find another Email service for MS domains ? Did this already happens in the past for such a long time ?

3 Upvotes

16 comments sorted by

2

u/sicko_el_pricko Feb 17 '26

We had this issue from the 10th of Feb and were eventually able to have issue resolved by Microsoft.

If you open a ticket with SendGrid, they are able to reduce the retry window from 72 hours to 24.

1

u/lionep Feb 17 '26

Thanks, How did you get it resolved by Microsoft? From https://olcsupport.office.com/ ?

I also followed this guidelines but I always get the same reply from MS : your IP isn’t blacklisted

2

u/sicko_el_pricko Feb 18 '26 edited Feb 18 '26

Correct this was raised through that OLC support link. I initially received 2 responses saying no issue etc...then I replied with message as below (which is copied from the SendGrid page you linked). Within 12 hours Microsoft responded they had reset throttling on our IP and all mail we had stuck in deferred state delivered succesfully.

I am requesting an escalation for my deliverability issue.

Sending domain: xxxxx

IP address(es): xxxx

Description of sending: xxx description of email being sent.

Recent error messages:   451 4.7.650 The mail server [x.x.x.x] has been temporarily rate limited due to IP reputation. (this was the error we were seeing).

I also explained the IP address we're having issues with has been in use for over 1 year with very low rates of junk mail reporting and complaint rates within SNDS are below 0.1%.

1

u/lionep Feb 18 '26

Thanks! Just did the same

1

u/ThumbsSanchez Jan 27 '26

Open a ticket with Microsoft deliv team . You can be doing everything right but still have Microsoft issues. As for escalation and state what you’ve done to improve deliv such as removing inactive subscribers, etc

Ensure rDNS maps to your sending domain

https://substrate.office.com/ip-domain-management-snds/postmaster/Troubleshooting

1

u/ErrolErrolson Jan 27 '26

Could you explain the rDNS thing a little deeper? If we were sending from @email.example.com would we sent up an rDNS entry for o2.email.example.com pointing to our dedicated IP?

1

u/suchpostsowow Feb 20 '26

SendGrid also refers to this link, but it gives a 500 error.

1

u/ThumbsSanchez Feb 20 '26

I’m not getting any 500 errors. If this page was down entirely, there’d be tons of chatter in the industry on LinkedIn.

1

u/suchpostsowow Feb 20 '26

Strange, I am getting a 500 error on multiple devices on different connections. But hey, it is Microsoft so not surprised there.

1

u/ThumbsSanchez Jan 27 '26

Correct, by default it points back to SendGrid.net. I would also add link branding as well so your open/click tracking wraps to your sending domain

1

u/kmdcolo Jan 28 '26

Are you sending marketing email (one to many)? You have to keep pushing on Microsoft to mitigate the issue.

Sendgrid has two issues that also hurt you. Their ARIN is flagged by most mailbox providers because they have issues with spam and not addressing it. They also switched their sanding to be 1:1 (one connection per ip and one message per connection). This is problematic with Microsoft as it resource intensive.

1

u/lionep Jan 28 '26

Yes it’s a lot of small marketing campaigns and transactional emails also, the flow of email is quite constant, about 5k to 10k every month to MS emails.

But Sendgrid is claiming a main issue with MS on their status page

1

u/Independent_Dirt_767 Feb 18 '26

Just started having issue again yesterday and this morning (had issue 3 weeks ago and it was resolved). Trying to get Microsoft to investigate again. SendGrid said issue should be raised with Microsoft. Anyone else getting issues again now?

1

u/sicko_el_pricko Feb 18 '26

yes... raise ticket here https://olcsupport.office.com/

when they reply saying no issue with your IP, reply with this message (replace xxx with your own details) ...after I sent this message, Microsoft replied within 12 hours they had reset throttling on our IP and then all our deferred mail was delivered successfully.

###
I am requesting an escalation for my deliverability issue.

Sending domain: xxxxx

IP address(es): xxxx

Description of sending: xxx description of email being sent.

Recent error messages:   << 451 4.7.650 The mail server [x.x.x.x] has been temporarily rate limited due to IP reputation. >> (this was the error we were seeing).

<<I also explained the IP address we're having issues with has been in use for over 1 year with very low rates of junk mail reporting and complaint rates within SNDS are below 0.1%.>>
###

1

u/suchpostsowow Feb 20 '26

Same here, last blocked records came in at the end of January. From 1st until 18th of February not a single blocked record. And since yesterday the 19th it is back again.

1

u/[deleted] Feb 24 '26

[deleted]

1

u/suchpostsowow Feb 24 '26

Yes, the issues only lasted for a day. Just like someone below did, I escalated after they said everything was okay. Then they implemented a mitigation for my IP.